CloudFront免费CDN配置入门教程
|
![]() |
![]() |
![]() |
| 【性价之王】 | 【线路之王】 | 【价格之王】 | 【配置之王】 |
| 【免费之王】 | 【香港首推】 | 【梯子之王】 | 【独服之王】 |
目录
在2021年的11月,亚马逊AWS对他的Always Free策略做出了一些改变,这篇文章主要介绍如何利用其中的CloudFront资源,下面就跟全球主机测评小编一起看看吧。
零、序言
CloudFront是AWS推出的CDN功能,依托于AWS的全球基础设施,拥有海量的节点和带宽资源,过去一直以高昂的价格令个人站长望而却步。很多服务商如腾讯云、QUIC.CLOUD等,其全球布局都是租赁的CloudFront的边缘节点。
2021年对于云计算行业也是个不太平静的一年,经历了CloudFlare怒怼AWS流量暴利和AWS彻底砍掉自家Educate优惠码之后,AWS对自家免费产品额度做出了一些改变。
| CloudFront | 提升前 | 提升后 |
| 流量 | 50G/月 · 免费一年 | 1T/月 · 永久免费 |
| 请求次数 | 200万/月 · 免费一年 | 1000万/月 · 永久免费 |
除此之外,EC2的免费流量额度也从之前的免费一年15G或各区域1G提升到了永久每月100G,这么看起来新用户的免费EC2实例也不是那么的鸡肋了。经过博主测试,以上的免费额度已经在12月生效,可以放心使用。在配置过程中,AWS机翻的控制台与英文文档间理解存在诸多不便,因此全文以英文控制台为例进行演示。
注意:本文为仅针对一般用途的非专业实践,并未完全利用CloudFront所具备的全部功能,更合理的高级功能应用请结合官方文档及个人实践探索,欢迎在评论区你的实践经验~
参考资料来源AWS Blogs:点击前往
CloudFront Developer Guide:点击前往
开始使用CloudFront,来到CloudFront的控制台(点击前往),要做的第一件事就是点击Create distribution通过引导新建一个CDN资源。整个引导其实是一个完整的单源站单规则配置流程,不过为了更加清晰的理解部分参数在此保持默认,后文第二节会对这些细节单独详细展开。
首先最开始的是源站配置,第一项Origin domain,只能填入一个解析到你源站的域名。如图如果你不想自己解析的话,可以利用nip.io项目在IP末尾添加.nip.io解析到源站IP。Protcol是取源协议,根据你的具体需求选择HTTP/HTTPS回源亦或者是匹配访问。
接下来是去设置默认的缓存行为,其中第一条是访问设置Viewer。Viewer protocol policy根据你对外访问需要决定是否将HTTP跳转到HTTPS;Allowed HTTP methods为允许的请求头,可以根据实际需要选择,简单概括文件下载场景可选第一条、静态网站可选第二条、动态网站必须选择第三条,如果无法明确判定自己需要直接选择第三条全部支持即可。
第二条是缓存设置和源请求设置Cache key and origin requests,作为默认规则建议分别选择CachingDisabled禁止缓存以及AllViewer将所有访客请求头转发到源站。
其他未提到的项目暂时保持默认(各个自定义名称的条目除外,看你要不要自己命名),然后拉到最下面点击Create distribution创建CDN资源。
这时候一个CDN资源就成功创建出来了,稍后你可在面板上看到为你分配的*.cloudfront.net默认域名,这也是你后续添加自定义域名所要指向的CNAME值。
进入CDN控制面板,第一个页面便是资源概览的General选项卡,在下方Settings栏右侧点击Edit可以进入资源的基础配置。前两项价格层级和WAF如其名,建议都保持默认(全部节点、无防护),关于WAF的内容放到第三节再单独解释。
接下来就是比较重要的绑定自己的域名,在Alternate domain name可以添加一个或多个自己的域名到这个资源,随后可以前往DNS将自定义域名通过CNAME指向前文提到的CloudFront默认域名。
随后同样是比较重要的HTTPS配置,我们先要前往us-east-1可用区的ACM(点击前往)导入自己的证书或者签发Amazon的免费证书,注意这里必须是Virginia区域的ACM否则CloudFront将无法读取到你的证书。点击Import导入自己证书,Requst签发免费证书。
这里推荐签发Amazon的证书,有效期395天且支持泛域名。如图填入自己的域名,选择合适的验证方式添加对应的记录即可,验证完成后很快就能够签发成功。
准备好证书后回到我们的CDN设置页面,在Custom SSL certificate选项卡下选择你刚刚签发的证书,安全策略建议选择TLSv1.1_2016以获得较为广泛的兼容性。
最后是IPv6选项,面向的访客位于中国大陆时建议关掉,面向海外的话可以保持默认的开启状态。其他未提及的选项保持默认即可,至此CDN资源配置完成。
2.2 源站配置(Origins)随后第二个选项卡即为源站设置,包括源站设置和包含主备切换功能的源站组设置。
在这里可以添加多个源站,如图在右上角点击Create origin可以创建新的源站。
和之前的新建流程一样,Origin domain填入一个解析到你源站的域名,可以利用nip.io项目在IP末尾添加.nip.io解析到源站IP,Protcol取源协议根据你的具体需求选择HTTP/HTTPS回源亦或者是匹配访问。此处需要注意若以HTTPS方式回源,源站必须配置有效、可信任的证书,否则节点取源会返回502错误。
源站组则可以将两个配置好的源站配置载入其中,一个作为主源站另一个作为热备源站,在源站请求出现如图错误参数时实现主备切换,若不需要这样的功能忽略这一步即可。
2.3 访问规则及缓存配置(Behaviors)接下来就是CDN配置中最为关键的一步,设置访问行为Behaviors规则,由此可以实现路径与源站的匹配以及节点缓存功能。
配置Path pattern是本节内容的核心,在一开始创建的引导中我们已将默认路径Default (*)设置为不缓存任何内容,因此针对每一种我们需要缓存的内容都要单独配置缓存规则。
选定我们需要缓存或者排除的内容依赖的是Path pattern(区分大小写),与CloudFlare的页面规则匹配类似,主要是通配符*和??的应用,常用的几种见如下表格。随后的设置内容即仅针对匹配的访问路径,首先就是选择2.2中配置的源站或源站组,以此也可实现不同路径的不同来源。
| Path pattern | 匹配的文件范围 |
/files/* | 指定/files/路径下所有文件 |
/*.jpg | 指定CDN资源内所有jpg后缀文件 |
/*.css* | 指定CDN资源内所有css后缀及包含参数的访问 |
/files/*.gif | 指定/files/路径下所有gif后缀文件 |
/a??.mp3 | 指定CDN资源内以a开头的mp3后缀文件 |
接下来Viewer protocol policy也跟第一步一样根据你对外访问需要决定是否将HTTP跳转到HTTPS;Allowed HTTP methods为允许的请求头,同样根据实际需要选择,无法明确判定自己需要直接选择第三条全部支持即可。
| HTTP请求头 | 适用场景 |
GET, HEAD | 提供文件下载等 |
GET, HEAD, OPTIONS | 纯静态网站或用于引用的静态资源等 |
GET, HEAD, OPTIONS, PUT, POST, PATCH, DELETE | WordPress等动态网站 |
接下来缓存设置Cache key and origin requests,匹配之前选定的路径及文件选择不缓存的CachingDisabled或最优缓存CachingOptimized规则;最后源请求策略依然设置为AllViewer将所有访客请求头转发到源站。其他给出的预置缓存规则均有针对性,也可以自己配置,这些针对性的内容若有需要请参考官方文档进行配置。
至此,通过Path pattern圈定范围并指定缓存规则后,我们可以实现对路径的缓存和对特定后缀文件的缓存。同样的,若缓存多个指定的后缀则需要依次添加多个规则,通过在Behavior页面移动规则上下指定其优先级(靠上者优先级更高)。
看到这里恭喜你,灵活运用以上内容你已经可以使用CloudFront作为CDN绝大多数的使用需求了~
三、其他要点3.1 CDN计费细则CloudFront的免费额度是每月1T流量和1000万次请求,计费项目包括HTTP请求、HTTPS请求、节点发往源站流量、节点流出到用户四部分流量,对于流量计费的理解如图所示。
使用CloudFront需要注意自己是否超出免费额度,超出后的价格是很贵的。账单是每天出一次,没有实时统计提供(控制面板的流量统计也有几个小时延迟),因此请不要将其用于易受攻击的站点。
3.2 502/503/504错误初次配置访问出现的错误一般如下:
502 ERROR The request could not be satisfied.
这个时候首先检查CDN域名是否已添加到源站,然后确认前文2.3中源请求策略设置为AllViewer将所有访客请求头转发到源站(主要是HOST未发往源站导致的),最后当使用HTTPS回源时确认源站是否安装了有效的SSL证书。
CloudFront提供有WAF防护,在前文未提到的原因是它是付费的而且价格并不便宜,因此并不推荐使用。以设置一条访问速率限制规则为例,你需要每月支付5美金的WAF规则费用以及1美元/条用于限流的ACL规则,此外还有请求次数的费用。
3.4 WebSocket支持CloudFront支持WebSocket功能,但是请不要随意滥用资源。
3.5 网络优化配置曾经在Lightsail CDN的体验中博主有提到关于网络的内容,AWS并未使用Anycast技术且在这段时间并未对网络做出改变,可以参考该文章第【三】部分。
https://luotianyi.vc/4324.html
四、结语CloudFront作为全球CDN巨头之一,提供的服务质量也是数一数二的,只是作为云服务厂商相比CloudFlare配置流程显得非常不友好。整体而言与CloudFlare各有优劣,如何选择可以自己权衡。
微信扫码关注全球主机测评微信公众号,我们将为您提供更多最新最全最专业的行业资讯以及主机促销活动
转载自:https://luotianyi.vc/5994.html
[AWS]历史优惠活动内容
猜你可能想看的VPS
- TmhHost:香港大带宽云服务器/季付8折/200带宽,120元/3月 香港VPS[主机]
- 香港的云服务器值得租用吗?有什么好处? 香港VPS[主机]
- 又有美议员窜访台,中国驻美大使馆:“中方将对美国的挑衅采取果断的反制措施 美国VPS[主机]
- 疯鱼云怎么样?香港CN2VPS首月14元,续费19元 香港VPS[主机]
- 啤啤云怎么样?香港CN2线路vps,有香港安畅机房,全部9折,38.7元 香港VPS[主机]
- tudcloud:香港vps终身7折,香港服务器终身9折,移动访问尤其优 香港VPS[主机]
- 互盟云怎么样?1核2G云服务器仅468元/年,香港云主机58元/月 香港VPS[主机]
- hosthatch:香港/芝加哥/伦敦等11机房VPS低至$17.5/年 香港VPS[主机]
- 魔方云cubecloud:香港CN2VPS/美国CN2VPS终身88折/ 美国VPS[主机]
- GreenCloudVPS:6折优惠,日本、新加坡、香港等KVM VPS 日本VPS[主机]
- 尊云服务器年末钜惠活动:4核8G5M云服务器仅99元/月,1188元/年 全球[VPS测评]
- 硅云香港云服务器促销活动:CPU性能100%性能,无需备案 香港VPS[主机]
- 硅云香港云服务器怎么样?硅云香港vps访问速度快不快? 香港VPS[主机]
- KVMCloud:1核/512M/40G硬盘/无限流量/美国/香港BGP 美国VPS[主机]
- 奇异互动:香港2核4G5M云服务器仅83元/月,700元/年;裸金属服务 香港VPS[主机]
- vpsplayer:新年活动_vps全部7.5折起_深圳BGP/美西Ce 香港VPS[主机]
- 腾讯云vps主机:288元/3年,1核/2G/50gSSD,北京/上海/ 美国VPS[主机]
- 特网云:香港高防云主机,香港/美国/韩国/大连/沈阳等地区,低至48元/ 韩国VPS[主机]
- HostHatch:香港/澳大利亚vps,1核/2GB/10GB NVM 虚拟空间(主机)
- 啤啤云:美国圣何塞vps低至30元/月;香港cn2vps仅43元/月起 美国VPS[主机]
- 跨境电商平台首选香港服务器 香港VPS[主机]
- ERP库存管理系统HTML5模板 - DreamsPOS 全球[VPS测评]
- 文物、沉船、村落!干旱导致大量遗迹重见天日 2022年干旱还要持续多久? 全球[VPS测评]
- 宝塔面板怎么放行端口?宝塔面板放行端口的方法 全球[VPS测评]
- JGKVM活动钜惠:美国cn2,香港cmi,大带宽vps,三网直连,10 美国VPS[主机]
- 乐趣云怎么样?香港美国云服务器首月8.8元,新增IP5元/个 美国VPS[主机]
- 企鹅小屋怎么样?深港IPLC专线销售 500M大带宽/2核1G内存/55 全球[VPS测评]
- 印象云,香港安畅CN2VPS终身8折1核1G22元/月,美国CN2高防V 美国VPS[主机]
- wikihost,微基主机:1核/1G/15G/100Mbps/香港vp 香港VPS[主机]
- 搬瓦工:美国香港cn2 gia线路VPS,10Gbps带宽,移动+联通企 美国VPS[主机]
转载请注明原文地址: http://140.238.13.167:12355/read-188564.html











