如何为已有WordPress站点安装SSL证书开启全局https访问
|
![]() |
![]() |
![]() |
| 【性价之王】 | 【线路之王】 | 【价格之王】 | 【配置之王】 |
| 【免费之王】 | 【香港首推】 | 【梯子之王】 | 【独服之王】 |
为自己站点安装SSL证书,开启全局https访问已经越来越重要,很多站长都已经把自己的站点悄然安装了SSL证书。蜗牛789最近也比较关注SSL证书的安装,这两天也在着手把本博客开启https访问,细心的朋友蜗牛789已经全站启用了https访问。下面为大家介绍下如何WordPress站点安装SSL证书开启全局https访问,分享下蜗牛安装过程中遇到的问题和解决办法,希望大家少走弯路。安装SSL证书前,请一定先备份好你的站点。
一、准备SSL证书想要给自己站点安装SSL证书,那么首先需要准备好SSL证书,至于是购买还是使用免费的,请自己选择。关于免费SSL证书,本博客就为大家介绍了四家,分别是阿里云、七牛云、腾讯云、Let’s Encrypt提供的,阿里云、七牛云、腾讯云免费证书使用期限都是一年,Let’s Encrypt的免费SSL证书使用期限是三个月。像阿里云、七牛云、腾讯云免费SSL证书至于一年后会收费还是怎样,暂时都不知道,所以能用一年就先用一年再说吧。对于便宜的SSL证书,蜗牛暂时还没有关注,如果在以后发现了适合的实惠SSL证书再推荐给大家。阿里云、七牛云、腾讯云免费SSL证书申请教程如下,可根据自己需要选择。
腾讯云免费DVSSL证书申请及第三方SSL证书托管教程阿里云0元购买赛门铁克DV SSL证书七牛云免费申请价值1900元/年的赛门铁克(Symantec)DV SSL证书Let’s Encrypt免费SSL证书申请及自动续期教程二、安装SSL证书关于安装SSL证书确实很重要,很容易出错。本博客也为大家介绍了在LNMP一键安装包、WDlinux lanmp一键安装包 、宝塔Linux面板、OneinStack一键PHP/JAVA安装工具搭建的VPS建站环境下如何安装SSL证书,其中LNMP一键安装包和OneinStack一键PHP/JAVA安装工具支持自动配置Let’s Encrypt SSL证书,可以一键帮大家申请和安装好SSL。而WDlinux lanmp一键安装包 、宝塔Linux面板目前还需要大家手动安装SSL。其中使用LNMP一键安装包v1.4安装建站环境配置SSL证书最为简单,在创建虚拟主机过程中不仅支持自动安装Let’s Encrypt SSL证书,还支持配置自定义SSL证书,不需要我们手动修改.conf文件就能自动安装。但缺点是LNMP一键安装包v1.4目前还处在测试阶段,可能不够稳定,另外LNMP一键安装包安装的建站应用没有可是的控制面板,那些喜欢有虚拟主机一样控制面板的朋友也许不太喜欢使用LNMP一键安装包来为自己VPS搭建建站环境。蜗牛789的SSL证书就是自己手动配置的,下面把自己在配置过程中遇到的问题分享给大家,让大家都能正确配置好SSL证书。
几款常用VPS面板配置SSL证书教程:
OneinStack一键PHP/JAVA安装工具Nginx环境手动安装SSL证书LNMP一键安装包v1.4为Linux VPS安装建站环境及配置SSL教程如何在宝塔Linux面板建站环境下配置SSL证书如何在WDlinux lanmp一键安装包建站环境下配置SSL证书教程1、SSL证书配置代码一定要安装正确。在安装过程中,很容易犯得错误就是,把证书配置教程的一段代码修改下域名和证书路径就直接复制到.conf,访问过程中感觉https能访问了,没有什么错误,但是等到你上传站点程序到网站目录,安装时,你发现无法安装程序,https访问某个php文件就是下载及访问站点都是403错误,使用https无法安装WordPress,但是使用http访问又正常了。蜗牛开始遇到这个问题到处找办法解决,一直没有找到解决的办法。后来认为自己代码是不是安装错误,结果一换方法还真的安装错了。下图为错误配置方法:
2、正确配置代码是,应该把SSL配置代码插入到原有代码之中,建议按下面位置插入。下面红字部分是加入内容,请根据自己域名和证书位置修改好代码加入,建议代码位置也和蜗牛的一致,以免出错。如果你配置正确了,发现https访问是不会出现403错误和直接下文件的。
server
{
listen 80;
listen 443;
server_name www.wnfree.xyz wnfree.xyz;
index index.php index.html index.htm default.php default.htm default.html;
root /www/wwwroot/www.wnfree.xyz;
if ($ssl_protocol = “”) { return 301 https://$server_name$request_uri; }
if ($host != www.wnfree.xyz) { return 301 $scheme://www.wnfree.xyz$request_uri; }
#error_page 404/404.html;
error_page 404 /404.html;
error_page 502 /502.html;
include enable-php-54.conf;
include rewrite/www.wnfree.xyz.conf;
ssl on;
ssl_certificate /etc/1_www.wnfree.xyz_bundle.crt;
ssl_certificate_key /etc/2_www.wnfree.xyz.key;
ssl_session_timeout 5m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:HIGH:!aNULL:!MD5:!RC4:!DHE;
ssl_per_server_ciphers on;
location ~ .*\\.(gif|jpg|jpeg|png|bmp|swf)$
{
expires 30d;
access_log on;
}
location ~ .*\\.(js|css)?$
{
expires 12h;
access_log on;
}
access_log /www/wwwlogs/www.wnfree.xyz.log
}
3、如果证书代码也配置好了,站点程序也安装好了,以WordPress为列,我们设置固定链接为html时,访问文章出现404错误,无法正常访问。但是链接没有改成伪静态是可以正常访问的。其实还是.conf出了问题,我们需要在.conf加上一段伪静态规则代码。所以真正正确的.conf配置如下:
server
{
listen 80;
listen 443;
server_name www.wnfree.xyz wnfree.xyz;
index index.php index.html index.htm default.php default.htm default.html;
root /www/wwwroot/www.wnfree.xyz;
if ($ssl_protocol = “”) { return 301 https://$server_name$request_uri; }
if ($host != www.wnfree.xyz) { return 301 $scheme://www.wnfree.xyz$request_uri; }
#error_page 404/404.html;
error_page 404 /404.html;
error_page 502 /502.html;
include enable-php-54.conf;
include rewrite/www.wnfree.xyz.conf;
ssl on;
ssl_certificate /etc/1_www.wnfree.xyz_bundle.crt;
ssl_certificate_key /etc/2_www.wnfree.xyz.key;
ssl_session_timeout 5m;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers ECDHE-RSA-AES128-GCM-SHA256:HIGH:!aNULL:!MD5:!RC4:!DHE;
ssl_per_server_ciphers on;
location ~ .*\\.(gif|jpg|jpeg|png|bmp|swf)$
{
expires 30d;
access_log on;
}
location ~ .*\\.(js|css)?$
{
expires 12h;
access_log on;
}
access_log /www/wwwlogs/www.wnfree.xyz.log;
if (-f $request_filename/index.html){
rewrite (.*) $1/index.html break;
}
if (-f $request_filename/index.php){
rewrite (.*) $1/index.php;
}
if (!-f $request_filename){
rewrite (.*) /index.php;
}
}
1、SSL证书安装好了,接下来就是修改数据库,把http链接替换成https,然后再在数据库管理面板导入数据库即可。其实修改数据库链接很简单,我们把备份好的数据库用“Notepad++ ”来编辑。然后使用“搜索”中“替换”来修改。数据库修改完成后进入你的数据库管理页面,找到你站点数据库点击进入,然后把修改好的数据库导入进入。
点击百度云下载Notepad++ 绿色版 提取密码: asca2、恢复原来的站点文件,在你备份包里找到“wp-content”文件夹,然后把里面的“plugins、themes、uploads”三个文件夹内容上传到你站点对应文件夹。然后你在访问网站,发现https访问及图片一切正常!
[WordPress教程]历史优惠活动内容
猜你可能想看的VPS
- 月神科技:香港安畅/沙田机房VPS,2核2G10M带宽仅20元/月 香港VPS[主机]
- 易探云:香港免备案云服务器年付6.8折,2核4G5M+10G数据盘仅79 香港VPS[主机]
- 长三角地区的算力需求规模到底有多大? 全球[VPS测评]
- Linux系统下安装Java JDK 全球[VPS测评]
- 2.45亿、成都公安(大数据基座-服务器)采购:神码、虹信、海康、超聚变 全球[VPS测评]
- 文物、沉船、村落!干旱导致大量遗迹重见天日 2022年干旱还要持续多久? 全球[VPS测评]
- 中国云计算,能啃的只剩硬骨头了 全球[VPS测评]
- 向日葵-漏洞科普:海外云服务器三种漏洞修复方法快收藏起来! 全球[VPS测评]
- 谷歌浏览器网址如何显示http,www,Chrome谷歌浏览器恢复地址栏 全球[VPS测评]
- 宝塔面板在香港服务器安装启动不了nginx怎么办? 香港VPS[主机]
- 六六云,2核2G香港云服务器/1000GB流量/50Mbps端口/KVM 香港VPS[主机]
- 八点云主机怎么样?香港2核4G5M带宽云主机,98元/月;国内4核8G云 香港VPS[主机]
- 桔子数据怎么样?美国、香港CN2云服务器2核2G10M带宽仅480元/年 美国VPS[主机]
- 触摸云:香港BGP/香港CN2/美国GIA高防CN2 GIA云服务器2H 美国VPS[主机]
- 锤子云:香港CN2云服务器15元/月,三网CN2线路回程,建站vps专属 香港VPS[主机]
- 香港cn2线路服务器哪里好?香港cn2服务器推荐哪家好? 香港VPS[主机]
- 香港站群服务器租用推荐,香港多IP服务器/VPS套餐(站群需求) 站群服务器[IP]
- 傲游主机:香港CN2高防云主机8折158元/月起(最高50G防御/2核2 香港VPS[主机]
- vmshell:香港不限速vps/200MBps大带宽VPS促销仅需$3 香港VPS[主机]
- 极光KVM:美国CN2VPS,全场6折,大带宽vps年付169元;香港c 美国VPS[主机]
- VoLLCloud:香港200Mbps不限速大宽带VPS,免费vps领取 香港VPS[主机]
- 孤狼云:香港安畅、沙田CN2 VPS,1核/1G/40G硬盘,10元/月 香港VPS[主机]
- TmhHost:香港大带宽云服务器/季付8折/200带宽,120元/3月 香港VPS[主机]
- locvps:香港云地多线路BGP云服务器,三网直连,6折终身优惠中,稳 香港VPS[主机]
- VoLLCloud:亚太地区香港200M/VPS月付低至3$,年付全场5 香港VPS[主机]
- 菜单选中标记CSS3动画效果 全球[VPS测评]
- 牛信云入选艾瑞《2022年中国跨境电商服务行业趋势报告》典型厂商 全球[VPS测评]
- LOCVPS,全新香港大浦CN2 VPS 2核4G内存3M仅54/月 香港VPS[主机]
- HostKVM香港云地VPS,2核4G内存折后$8.4/月,30M大带宽 香港VPS[主机]
- 空空云怎么样?香港CN2-GIA VPS,带宽2M,月付15元 香港VPS[主机]
转载请注明原文地址: http://140.238.13.167:12355/read-150659.html











